Problem with building server

General development discussion forum

Problem with building server

Postby Shiran » January 2nd, 2015, 7:13 am

Hi everyone,
I have look in the forum but i didn't found informations.
From the swganh installation guide i'm setting up a server but when i do the cmake -G "Visual Studio 11" ..
I always receive the answer : Gamesystems does not contain Cmakelists.txt file

Anyone have a solution ?

Happy new year
Shiran
 
Posts: 5
Joined: January 2nd, 2015, 6:59 am
SWG Official Server: Chimaera

Re: Problem with building server

Postby Obi-Two » January 3rd, 2015, 11:42 am

Sadly we are currently not able to offer support on our projects,

I will try and give you some pointers form my own experiance if I can,

what repository are you building??

also what instructions??

Obi


Ps I've moved this to a more general disussion thread
Thanks
Obi-Two

Quality Assurance
Star Wars Galaxies:A new hope
there is another...

Server by : Hostwind
Project : SWGANHServices/SWGANHJava
Obi-Two
SWG:ANH Staff
 
Posts: 248
Joined: January 3rd, 2009, 9:37 am
Location: Manchester, England
SWG Official Server: Ahazi

Re: Problem with building server

Postby Shiran » January 5th, 2015, 1:51 am

Hello Thanks for your answer.

I'm using the 0.51 version
The instruction i need are theses once : http://swganh.com/anh_docs/book/install ... ndows.html

At the end i have copy the file Cmakelists.txt file from another directory and it worked.
Now i'm blocked when i do the "cmake --build ." it finish with 5 errors telling that it can't find python lib

The python i have installed is the python 3.4, i can't find the 3.2.

It's maybe easier to make the server with Linux ? what do you think?
Shiran
 
Posts: 5
Joined: January 2nd, 2015, 6:59 am
SWG Official Server: Chimaera

Re: Problem with building server

Postby Obi-Two » January 5th, 2015, 12:54 pm

yeah looks like your trying to build the ANH game server,
sadly this ones a massive pain, I've never got ti tto work and we stopped supporting it,

this is the current main project. https://github.com/swganh/mmoserver
this also has issues but I'll try and helpo you where I can, I'm currently working on a few bug fixes for the build process.

Obi.
Obi-Two

Quality Assurance
Star Wars Galaxies:A new hope
there is another...

Server by : Hostwind
Project : SWGANHServices/SWGANHJava
Obi-Two
SWG:ANH Staff
 
Posts: 248
Joined: January 3rd, 2009, 9:37 am
Location: Manchester, England
SWG Official Server: Ahazi

Re: Problem with building server

Postby Shiran » January 5th, 2015, 1:18 pm

Oh ok Thanks i Will try the one you tell me. :-)
Shiran
 
Posts: 5
Joined: January 2nd, 2015, 6:59 am
SWG Official Server: Chimaera

Re: Problem with building server

Postby Shiran » January 5th, 2015, 3:33 pm

I have download the sources you told me but when I click on BuildServer.bat it download the mmoserver-deps-0.1.2.zip but it's corrupted nothing inside so I can't continue.
Shiran
 
Posts: 5
Joined: January 2nd, 2015, 6:59 am
SWG Official Server: Chimaera

Re: Problem with building server

Postby Obi-Two » January 6th, 2015, 6:29 am

Basically the buildserver file is tring to download dep files that aren't there anymore. You'll need to fool it ( I'm working of a fix for this currently) The Deps from the ANH Game Server will work but your going to have to fool the .bat into thinking that the one it needs (basically rename it to what ever the empty zip file was (you may nee to extract the vendor file and rezip it)
https://github.com/anhstudios/swganh/downloads <--- to the depds, I got the latest 0.5.1

Once you have the deps zip file from the other project. You might have a problem with height maps, again you can manually down load these from the other projects GitHub unpack them yourself inthe data/height maps folder in your directory
https://github.com/anhstudios/swg-heightmaps/downloads <--- download and extract each to the heightmap directory (as above)

There are a few other deps you'll need to gather too. a good googling and you should find all you need.

I was hoping to be of more help than this but I hope i've pointed you and anyone else in t the right direction.
I an hopefull to have a few of the bugs ironed out soon(ish) to make this a more automatic process, as its supposed to be.

There seems to be a lot of solutions files missing also, I will attepmt to hunt them down adn supply links as and when I can
Good luck
Obi
Obi-Two

Quality Assurance
Star Wars Galaxies:A new hope
there is another...

Server by : Hostwind
Project : SWGANHServices/SWGANHJava
Obi-Two
SWG:ANH Staff
 
Posts: 248
Joined: January 3rd, 2009, 9:37 am
Location: Manchester, England
SWG Official Server: Ahazi

Re: Problem with building server

Postby sobermeyer » February 18th, 2015, 11:11 pm

I've spent the last couple of days trying to get this compiled myself and have come across a number of issues as well and wanted to know if anyone has been able to get this compiled and running as of lately - within the past couple of months.

Any help would be very much appreciated as I've tried both the SWGANH and the MMOSERVER with no luck thus far. :(
sobermeyer
 
Posts: 1
Joined: February 13th, 2015, 5:25 pm

Re: Problem with building server

Postby Obi-Two » February 19th, 2015, 2:42 am

Hi Sobermeryer,

I've build and ran the server but it will require some tinkering about,

sadly I've not been able to log into the zone(I'm putting this down to a DB issue, I'm hoping to resolve soon)

see my post here
http://swganh.com/anh_community/viewtopic.php?f=21&t=1532&sid=7f30711d09529284305a93e51253b344
Obi-Two

Quality Assurance
Star Wars Galaxies:A new hope
there is another...

Server by : Hostwind
Project : SWGANHServices/SWGANHJava
Obi-Two
SWG:ANH Staff
 
Posts: 248
Joined: January 3rd, 2009, 9:37 am
Location: Manchester, England
SWG Official Server: Ahazi


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 0 guests

cron